Tail light install help

Technical info about the TU, maintenance tips/questions, how-to guides, aftermarket accessories, projects
llmattie
Posts: 3
Joined: July 22nd, 2017, 5:58 pm

Tail light install help

Postby llmattie » August 11th, 2017, 9:58 pm

I am trying to install a new tail light but I am not getting any power to it, I tried reinstalling the old light but same issue. Does anyone have any recommendations? Also, I noticed the netraul light is not working. Pretty sure I blew a fuse changing lights.

User avatar
TomSXM
Posts: 471
Joined: December 16th, 2012, 5:20 am
Location: Zurich, CH | SXM

Re: Tail light install help

Postby TomSXM » August 12th, 2017, 8:16 am

Check the fuses. You should have a spare in the fuse box. I did the same thing, a number of times...
'94 E280 (W124) | '95 SL500 (R129) |'02 Triumph Bonneville | '04 Brabus Roadster (452) | '07 XJR (X350) | '12 TU250x

User avatar
meowguy
Posts: 49
Joined: June 26th, 2017, 4:14 pm

Re: Tail light install help

Postby meowguy » August 12th, 2017, 8:24 am

Looks like it goes into fuse box 3 on the schematic. As a rule you want to disconnect the battery whenever working on electrical.
"The closest I can get to flying on land is riding on a small motorcycle." Devon Biek of Janus American Motorcycles

llmattie
Posts: 3
Joined: July 22nd, 2017, 5:58 pm

Re: Tail light install help

Postby llmattie » August 12th, 2017, 12:37 pm

Thanks, it was the fuse. The fuse box is found right next to the battery if anyone else has this problem.


Return to “Maintenance, Mods & Accessories”

Who is online

Users browsing this forum: No registered users and 6 guests